Indico Hands-On Session - Conferences

The goal of this Indico hands-on session is to familiarize with the management of a
conference and discover the main features of the tool.

All information to perform the following exercises can be found in 2 places:
* The Indico website help: http://indico.cern.ch/help.py
* Ask the instructor.

Hints described below are usually not in the user guide, but save time and mouse clicks.

Some of the exercises will be done with the person sitting next to you.

Agenda

¢ Short presentation by the teacher, presentation of Indico features.

* Hands-On: please complete all the following steps. If you don’'t know how to achieve
something, check the online Indico user guide or ask the teacher.

* Open questions and tutorials: feel free to ask any question and procedure, the teacher will
try to address the problem.



http://indico.cern.ch/help.py

A) Create a Conference

1. Log in using your account.

2. In the “Hands-on Training” category, create a conference and give it your full name as a
titte, starting today at 08:00 and finishing tomorrow at 18:00. The full path is Home >
Departments > HR > Training > Technical Training > Office software > Indico > Hands-on
Training.

3. After validating the conference creation form, you are redirected to the management area
of the conference.

4. Go back to the display of your conference to see how it looks like. Hint: fo go back to the

l Switch to event page

event home page you can click in the button that is in the menu on

the left.

B) Modify the conference web portal

Configure the menu of the conference

In the event home page there is a menu on the left. We are going to customize the items in
that menu.

5. Go back to the management area of the conference (click on -). Now, click on the
“Layout’ option that you can find in the menu on the left. And open the tab “Menu”

6. Enable the “Speaker index” link. Hint: click on the “Contribution List” item and ‘Activate’ it.
7. Change the title of the “Scientific Programme” link to “Conference Programme”.

8. Create a new link named “Conference Home Page” and pointing to http://cern.ch Hint: use
the button “add link”

9. Create a new page named “How to come to CERN” and use the text area to create some
content. Hint: use the button “add page”

10. Create a new spacer. Hint: button “add spacer”.

11. Move up the spacer between “Conference Home Page” and “How to come to CERN”.
Hint: click in “conference home page” to see the “move” arrows.

12. Check the result by going back to the conference display. Hint: Sl o evenl poge

General display Options

13. Go back to the “Layout” option of the management area and change the color of the
background and text of your conference. Hint: you can find it in the tab “Layout
customization”. Click in the icon with many colors.

14. Add a logo to your conference (for example this one:
http://cdsweb.cern.ch/record/1446633/files/LogoEN_image.jpg?subformat=icon

you will need to right-click on the image, select Save Image As... and then store it locally
before uploading it to your conference)

Switch to event page

15. Check the result by going back to the conference display. Hint:

Special Announcements

16. Go back to the “Layout” menu of the management, the tab “Conference header”, and
enable the Announcement feature.

17. Enter this text “WARNING: REGISTRATION CLOSES IN 5 DAYS” as a special
announcement (don’t forget to save)
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18. Check the result (the warning should appear at the top of the event main page,
underneath the conference title).

Hint: The “Now playing” option is used to display the list of talks that are currently going on.
To be used only on the dates of the conference.

C) Conference programme and call for abstract

Prepare the Call for abstract
You now act as the conference manager

19. Go to the “General settings” menu of the management area and create two new “Types
of contributions”: Paper and Poster. Hint: You will find it at the bottom of the page.

20. Go to the “Programme” menu and create two new tracks: “Computing” and “Accelerators”.
21. Check the result by clicking on the “Conference Programme” link on the conference home

page. Hint: go to the event home page by clicking on l Swish o evenl page ‘

22. Back to management area and click on the new “Call for Abstracts” menu then on the
“Setup” tab. Enable the abstracts submission by clicking on the “Enable” button.
23. Check your conference display page: a new “Call for abstracts” section appears in the

l Switch to event page ‘

left menu. Hint: go to the event home page by clicking on
24. Go back to the conference management area and define a notification template for
accepted abstracts. Hint: notification template is an email that will be automatically sent under
certain conditions, normally acceptance, rejection or merging of abstracts. Click in “Call for
Abstracts” menu, “Reviewing” and “Notification templates” tab and add a new notification
template (“add” button down the page). Enter the following fields:

Title: email for accepted abstracts Hint: this is just a name to save the template.

To addresses: submitters
Subject: [{conference_title}] Your Abstract has been accepted!
Body:

Dear {submitter_first_name} {submitter_family_name},

your abstract "{abstract _title}" has been accepted in track
"{abstract_track}".

you can access it here:

{abstract_URL}

Best regards,
{conference _title} organizers

Hint: the tags like {conference_title} should be perfectly written or an exception will be
raised. You can use the 'Insert’ on the right box in order to aggregate a tag to the
email body or subject.

Choose a condition for which this email will be sent: select “in status ACCEPTED”, the
contribution type “any”, track “any” and submit (click 'Save'). This email will now be sent each
time an abstract is approved. You can define similar templates for rejected abstracts, merged
abstracts...

25. One can check the result by using the “preview” tab. Hint: you should already have at
least one abstract to see a preview.

26. Now nominate a track coordinator for the “Computing” track: Go to “Call for Abstracts” >
“Reviewing” > “Team” and click on “Add existing” fro the track “Computing”. Then select your
neighbor as track coordinator. Hint: the frack coordinator will propose to accept or reject the
abstracts that are sent to your conference and for the track “Computing”.



Submit an Abstract
You now act as the author and submitter of an abstract in your neighbor’s conference

Hint: you will submit an abstract to your neighbor’s. Then, this abstract will be accepted or
rejected by the conference organizer.

27. Go to the display page of the conference created by your neighbor
28. Submit an abstract in the “Computing” track (“Track classification”).
29. Check the “View my abstracts” link and modify the title of your abstract

Propose to approve an Abstract
You now act as the “Computing” track coordinator of your neighbor’s conference

30. Click on the “Manage my track” link and select the abstract you have just submitted
31. Propose this paper to be accepted with a comment to justify your choice (by clicking on its
title in the list and then the button “propose to be accepted”).

Approve an Abstract

You now act as the conference manager of your conference

32. Go back to your conference and to the management area, “Call for Abstracts” menu. If
your neighbor has reached the same point as you, you should see his/her abstract in the “List
of abstracts”. Click on the title of the abstract, and then accept it. Note that an automatic
email will be sent to the author, thanks to the notification template that you have done during
the step 24.

33. Once an abstract is approved, it is automatically converted into a contribution and will
appear in the “Contributions” menu. Therefore, check the “Contributions” menu to make
sure the abstract appears there.

D) Preparing the conference timetable

Scenario: you’re organizing a two-days conference on the subject of computing. The first day
is dedicated to software, while the second day is centered on hardware. Since there’s only
one subject being discussed, there will be only one session spanning the two days, with one
interval of time for each day. The timetable for the conference will look like this:

Day 1 Day 2

08:00-12:00 Computing: Software 08:00-12:00 Computing: Hardware

34. Go to the “Timetable” menu and add a new session with the title “Computing”. Set the
date as the first day from 08:00 to 12:00.

35. Add a new block for the same session. This time choose: add new > session > add
another block to: Computing. The date should be the 2™ day from 08:00 to 12:00.

36. Define sub-titles for both session blocks. Click on the box for the session block on the 1%
day and Edit > Block properties. Add the sub-title “Software”.

37. Now add a sub-title for the 2™ session block on the 2™ day. This time the sub-title is
“‘Hardware”.

38. Go to the “Contributions” menu, select the submitted abstract and change the session to
“Computing”. Note: click on the title of the abstract to access the edition page. Choose the
new session and don't forget to click “change”

39. Go back to the Timetable, open the interval timetable for the session “Computing:
Software” (user the link inside the balloon popup: View and edit this block timetable).
Add the contribution inside this session. Note: user Add new = Contribution.

40. Go to the conference display page and check the result by clicking on the “Timetable” link
in the left menu.



E) Using the registration feature

Create a Registration Form
You now act as the conference manager of your conference.

41. Go to the menu “Registration”. Click on it and enable the registration form display (this
will create a new “Registration” link in the menu of your conference home page).

42. Go to the conference home page and check the result by clicking on the “Registration
form” link in the left menu.

43. Being warned when someone registers. Go back to the management area,
“registration” -> “setup” page. Click on the modify button and add your email address in the
“Email organisators” -> “To list” field. You will then receive an email each time a new
participant registers. Hint: you will notice later because one of your neighbors will register to
your conference.

44, Enabling the e-payment. Go to the “e-payment” tab and enable the e-payment. Do not
forget to choose the right currency.

45. Changing the fields in the registration form. On Ehe; “Setup” tab, disable thg s‘ection

“Further information” of the form by clicking on the icon B, The icon turns to red ®lwhich
indicates that the section is disabled. Disable also the “Sessions” section.

46. Edit the “Social event” section by clicking on its title. Add two entries in this section
“Conference Lunch” and “Conference Dinner”.

47. Go back to “Registration” -> “Setup” and add a new section to the form (“new sect.”
button).

48. Click on the title of this new section (“Miscellaneous information 07) to edit it. Change the
title to “Conference Objects”.

49. Add a new general field with caption “Tee-Shirt”, type “Multiple choice/checkbox”,
“billable”, price “15”.

50. Add also a “Mouse Pad” for “10”.

Register
You now act as a participant.

51. Go to your neighbor’s conference and register in.

Manage the participants
You now act as the conference manager.

52. Displaying the list of registrants. Go back to your conference and in the management
area, ‘registration” menu -> “registrants” tab.

53. How to choose the columns we want to display for the registrants list. Click on the
link Columns to display. Choose some fields you want to display, by clicking on the M icon
next to them. Then validate with the “apply” button. All the registration fields now appear in
the list. Hint: you will see that the chosen fields will show now as the headers of the list.

54. Exporting to other formats. Export the list of participants to Excel by clicking on the
Excel icon. (Only the fields selected in the previous step 53 will appear in the export).

55. Getting statistics. Use the button "Show Stats” to get attendance statistics.

56. Send email. Click the button “email” and check the functionality. Here, you can define an
email template and then Indico will send a personalized one to every participant. So, you
write 1 email, Indico sends many to the individuals.

57.Creating badges for participants. Go to the “Tools” menu and choose
“Badge/Tablesings”.

58. Create a new badge template, based on CERN. You can play moving the content around,
modifying the fonts, inserting more information. Give it a name and save it.

59. Print the badges for all the participants by clicking on “Try Selected Template”.



F) Other features

60. Reading Logs. All the important actions done through the management interface are
accessible through the “Logs” menu with the date and the user who did the action.

Congratulations, the Indico hands-on session is complete; please feel free to ask any
question and further details on Indico.




	Agenda
	A) Create a Conference
	B) Modify the conference web portal
	Configure the menu of the conference
	General display Options
	
	Special Announcements

	C) Conference programme and call for abstract
	Prepare the Call for abstract
	Submit an Abstract
	Propose to approve an Abstract
	Approve an Abstract

	D) Preparing the conference timetable
	E) Using the registration feature
	Create a Registration Form
	Register
	Manage the participants

	F) Other features

